µTune and midi out question

frontpage Forums Product questions and support µTune µTune and midi out question

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #8795

    Hi, I’ve had a uTune for a while and very happy with it, but now I’m trying to get some particular MIDI functionality and not sure (1) if it’s possible and (2) how to configure it properly.

    Here’s what I’d like to do: I would like to use the MIDI output to send note messages to a Pisound device (Raspberry PI-based). The Pisound supports MIDI via both USB and DIN in/out.

    I am already running my own software (in Csound) on the Pisound that handles the job of taking MIDI input from a keyboard and then translating it to the proper frequency based on the scale I have loaded. So all I need from the uTune output is note messages — I intend to get MIDI input from the uTune instead of from a keyboard.

    Here’s my uTune config:
    – all midi outputs set to channel 1 with tuning off
    – added routing of notes from CV to USB (it was already configured to route CV to DIN)

    When I connect uTune to Pisound via USB, I expected the Pisound to see a new MIDI device, but it does not. Also, when I have USB plugged in, the uTune seems to freeze up (i.e. the Info display stops updating even though CV is streaming in) and I have to cycle power to get it working again.

    I also tried using MIDI out (DIN) from the uTune, but the Pisound is still not seeing anything.

    I also tried switching the uTune MIDI output config to “Controller” (not sure what this really means, but I thought I would try it) and this makes no difference that I can see.

    Is is possible, what I’m trying to do? And if so, what am I doing wrong? I’m using firmware 1.11.



    To me this sounds like the problem is the USB connection, not your settings.
    I don’t know anything about the picosound and whether it is compatible with the µTune or not.
    However, given that µTune freezes, I strongly recommend to install a stable firmware version (not the 1.11 beta). USB is well tested here and should work

    A new note massage is only generated, when µTune sees a gate-in.


    Thanks, will try this very soon.

    FYI, the Pisound is a soundcard board that fits on a standard Raspberry Pi, providing stereo input/output and DIN in/out. I was connecting the uTune USB to one of the standard RPi USB ports, which I have used successfully with a range of MIDI devices, including keyboards and controllers with buttons and sliders.


    Sorry for the delay in following up – was not able until now to take the time to change the system. I reverted to firmware 1.05, but then the uTune stopped responding to CV 1 input. My Pi was able to see the device on USB, but I didn’t not get any note events (I use both CV 1 and CV 2, so even though CV 1 was not working, CV 2 was). I had to go back to 1.11 to get CV 1 input working again.

    As an experiment, on 1.11 I connected USB to a laptop (running Debian Linux), and the uTune froze up just as it did when connected to the Pi.

    In summary: I can’t go back to 1.05 because I lose an CV input, and still can’t get MIDI output with either 1.05 or 1.11.

    So, I am still happy with the CV/CV quantizing, but I’m disappointed not to have the MIDI output so that I can integrate my modular system (which is generating the notes) and my Csound code on Pisound, which is written to respond to MIDI input (this work with a keyboards but not yet with uTune).


    Someone else just reported a similar issue with usb and the 1.11 beta, so there seems to be a bug.
    regarding the cv input on 1.05, this can only be a calibration issue. Can you boot into 1.05 and check the settings in MISC->EXPERT->ADC/DAC CAL ?

    OR (if you have HW v. 17) you might need to do this:
    https://tubbutec.de/blog/%c2%b5tune-rec … -cv-input/

    (but only if you have HW17)


    Hi, sorry for another long delay in replying.

    I tried reloading 1.05, still have the problem where it is not responding to input on CV 1. Here are the values under ADC/DAC CAL:

    Chan 1, 0V: 1998
    Chan 2, 0V: 2034
    Chan 1, 10V: 64231
    Chan 2, 10V: 64203
    10V to CVIN1 -> FBC0
    10V to CVIN2 -> FC90

    I have not changed anything here, as I have no idea what change to make. These are the exactly the same values I see when I run 1.11, and both CV 1 and CV 2 inputs are working fine with 1.11, just not MIDI. I have HW18, so I have not applied the recalibration procedure for HW17.

    In the meantime, I am back using 1.11 for CV quantization and a Doepfer A-192-2 for MIDI output (which works fine because all I need is the note number — my Csound app at the destination is handling the tuning based on the note number).

    It’s pretty cool to have the tuning quantized by the uTune in the modular rig match the tuning in my Csound app. But I really look forward to be able to use the uTune for MIDI so that I don’t need to take up rack space with a separate MIDI module (plus a mult to route the sequencer CV to both the uTune and the Doepfer) as I am doing now.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.