Juno-66 No Waveforms

frontpage Forums Product questions and support Juno-66 Juno-66 No Waveforms

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
  • #9278

    Hi All

    I just finished installing the Juno-66 into my 60. It all went smoothly but now I’m not getting any waveforms. Noise, filter, chorus and Env work fine. I also installed the filter and pitch control mods.

    Any idea what it could be?



    Is the filter tracking working?

    If so: sounds like the DCO dividers are not running.
    Can you measure a rectangular waveform at pin 10,13,17 of IC 55?

    Check all the Pins on the Juno-66 for continuity and shorts .
    Especially Pins 10 – 23 and 35, 36, 38

    You can also post a photo of the installed Juno-66, sometimes this helps..


    Thanks for the reply!

    Yes the filter tracking is working. No shorts on the cpu pins on top. I’ll check continuity next.


    Going to grab a scope but for now I can measure 3.9 VDC on pins 10, 13 and17 of IC 55



    Ok I checked continuity on all those points and everything is fine. No shorts on the socket either. I can see no waveform with a scope on pins 10, 13 and 17 on IC 55.

    Here’s a pic. What should I try next?



    So I’ve doubled checked everything. I have continuity all all pins including the ones not mentioned as critical and it all seems ok.

    Sadly it’s still not working 🙁

    I have no waveform on the pins of IC55 and no sub, saw or pulse waves. Noise still works and filter os tracking.

    I’m really not sure what else to do at this point.

    Any help is greatly appreciated.



    very strange.

    If you can: Put in the original CPU, see if that works. Just to make sure it is not a fault with the Juno-66.

    You posted a picture of the bottom of the PCB, but most of the connections are on top, traces on the bottom are just going to the DCB interface which is not used any more. Can you also post a picture of the top with the installed Juno-66 ?
    I attached part of the schematics. are all the data and control pins of IC55 connected to the Juno-66 ?


    Thanks for your response.

    I cut the original cpu out so I can’t put it back in.

    Yes all the data control pins are connected.

    I’ll take a picture of the top now. I have the schematic and I have already checked every point and it all tests good for continuity and no shorts.


    12686_image_5 (1).jpg


    Thanks a lot! This helps!
    There seems to have been a mistake during production and one of the two wires on top of the Juno-66 is soldered in the wrong place.
    We somehow must have missed this during testing..
    This is most likely the cause of your problem.

    Attached a picture, just move the wire to next pin as shown

    I would also like to apologize for the troubles and the time you spent on this. I sent you a coupon code via mail..


    That was it!!! It works now.



    I know this was already solved, but just in case it helps someone else I had similar symptoms when I first installed mine – no one wave was completely gone, the other was still there but almost inaudible and very distorted (It was a couple months ago so I don’t remember which was which and I don’t remember if the sub oscillator had any problems), high noise floor and the filter sounded distorted when I brought up the resonance. In my case what had happened was that a stray bit of solder had made a tiny bridge between the point where the 180k resistor is soldered to the bender board and the pad directly below that point in the photo on the manual. It was easy to clean up and no harm was done to anything.

    The production flaw in the OP’s JU66 is probably very unlikely to happen again so I’d suggest checking the bender board for shorts first for anyone having similar issues.


    I installed the Ju 66 and I’m having the same issue…Can I trouble shoot by disconnecting the red wire going to the bender board??


    I should also mention that the waveforms were working for a short time but they would turned off when I pressed the arp button and turn back on when I pressed it again. Then they disappeared for good. Filters and envelopes, LFO all seem to work. I get a basic beating sound when arp is on.
    Any insight would be greatly appreciated. Thanks!!


    Please check for shorts and open connections

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.